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1 Introduction 
 

This manual aims at getting you started with the Leaf Knowtator text annotation tool in the Protégé 

environment, for the specific purpose of curating primary research papers focusing on the study of 

Arabidopsis leaf growth and development. 

First, we will tell you how to download and install all the necessary software. Then, we will introduce 

you to the Leaf Knowtator annotation system. Finally, we have included some general guidelines for 

creating your own knowtator project (Chapter 7). 

All necessary files are either available from dedicated public websites listed in the document or from 

www.agronomics.ethz.ch. 

We strongly recommend the following and ordered tasks for you to get familiar with Leaf Knowtator: 

1. Install and configure the software (Chapters 2 to 4). 

2. Get an overview of the Leaf Knowtator functions by reading carefully Chapter 5. 

3. Read the separate „Annotation structures‟ document. 

4. Give it a try with the training examples. 

Leaf Knowtator Contributors: Do not change the structure of the Leaf Knowtator system (relations 

and corresponding slots)! 

 

Note: The manual was optimized for Windows users. Please, consult Knowtator FAQ for MAC 

http://knowtator.sourceforge.net/ if necessary. 

  

http://knowtator.sourceforge.net/
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2 Installation of the Protégé software and Knowtator plug-in 
 

2.1 Installation of Protégé  
 

Download Protégé version 3.3.1 http://protege.cim3.net/download/old-releases/3.3.1/full/ 

Protégé is based on Java Virtual Machine (Java VM). You need to check if you have Java already 

installed on your computer. You can download both versions with or without Java program 

implemented. 

Choose version according to your operating system. Launch the installer and follow through with the 

process. 

 

Note: It is important to use the old version of Protégé since Knowtator only works with that. 

 All versions of Knowtator require Java 5.0 or higher.  

 Knowtator 1.7 and above requires Protégé 3.3. Knowtator plug-in does not work with 

Protégé 3.4.  

 

Useful information can be found: http://protege.stanford.edu/. 

 

2.2 Installation of Knowtator plugin 
 

Download Knowtator 1.9 beta 2 plugin from: 

http://sourceforge.net/projects/knowtator/files/Knowtator/(knowtator-1.9_beta2.zip).  

Unzip the Knowtator folder if it is possible directly to the Protégé plugins directory (e.g. C:\Program 

Files\Protege_3.3.1\plugins) or to any folder then copy it to the plugin directory. 

 

Useful information can be found: http://knowtator.sourceforge.net/. 

 

In the case of successful installation, Protégé can be launched (you might need to look for the 

launching shortcut in the Protégé folder). 

 

  

Opening screen provides options to start a new project or continue with an old one. Click on the „New 

Project…‟ button. In the next window, select the Project Type „Protégé Files (.pont and .pins)‟. 

 

  

http://protege.cim3.net/download/old-releases/3.3.1/full/
http://protege.stanford.edu/
http://sourceforge.net/projects/knowtator/files/Knowtator/
http://sourceforge.net/projects/knowtator/files/Knowtator/knowtator-1.9-beta2/knowtator-1.9_beta2.zip/download
http://knowtator.sourceforge.net/
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Screenshot of a new Protégé project: 
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2.3 Starting a new Knowtator project 
 

1. When launching Protégé, choose option of New project…  

 Or close welcome dialog box/current project and select Menu→File→New Project 

 

2. Select the option Protégé Files(.pont and .pins) 

 

3. Saving project Select Menu→File→Save Project 

Note: You have to save the project with a dummy name first in order to start working with Knowtator. 

 

4. Select Menu→Project→Configure...  

 

5. Select the tab labeled Tab Widgets  

 

6. Select the checkbox labeled Knowtator and click 'OK' 

 

7. Confirm Knowtator. Click OK. 

 

8. A dialog titled „Save?‟ appears that asks you whether you want to save your project. Click 

'Yes'.  

 

9. Configuration Reset. Click OK. 

 

Knowtator Tab is added to your screen: 

 

 
 

 

Mainly, you will work with the Knowtator and the Classes Tabs therefore we recommend hiding 

unnecessary tabs 

 

1. Select Menu→Project→Configure...  

 

2. Select the tab labeled Tab Widgets  
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3. Uncheck all the unwanted tabs. 

 

4. Press OK. 
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3 Installation of the Leaf Knowtator framework 
 

3.1 Sharing an existing project 
 

Knowtator works with relatively small files. Sharing the project only requires sending/copying six 

crucial files located in the same folder, namely: 

 knowtator.pprj 

 knowtator.pont 

 knowtator.pins 

 “your project name”.pprj 

 “your project name”.pont 

 “your project name”.pins 

 

Knowtator pprj/pont/pins contain important frames for the plug-in. They are automatically copied to 

the same folder with the project you work on. The project pins file contains all the annotations, pont 

file contains mainly the structure of the annotation project and personal settings (annotator, colour 

coding etc). You can use the pprj file to launch the project. 

 

Note: You should never call your project „Knowtator‟. 

 

In addition to these, you need to share the folder with the original text sources.  

 

Note: Don‟t forget to make regular back-up of these files with the text sources collection in order 

avoid loss of valuable data. 

 

3.2 Sharing the Leaf Knowtator annotation scheme 
 

We have created a stripped down version of our annotation scheme. The project is called Leaf 

Knowtator.  

 

This corresponding folder, called „Leaf Knowtator‟, contains: 

 knowtator.pprj 

 knowtator.pont 

 knowtator.pins 

 Leaf Knowtator.pprj 

 Leaf Knowtator.pont 

 Leaf Knowtator.pins 

 

The Leaf Knowtator folder also contains a folder for text sources called „New papers‟. At the moment 

that only contains a „Training document.txt” file that helps you to get familiar with the Leaf 

Knowtator annotation structure and working with Protégé/Knowtator. 

 

1. Copy the whole „Leaf Knowtator‟ folder into C:\Program 

Files\Protege_3.3.1\examples.  

 

2. It is important to keep this project intact and to save your own with a different name. 

So, open the original Leaf Knowtator project Select Menu→File→Open 
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3. Click Yes when prompted to save changes to the current project. 

 

4. Navigate to C:\Program Files\Protege_3.3.1\examples\ Leaf Knowtator. 

 

5. Click on „Leaf Knowtator.pprj‟. The actual Leaf Knowtator window appears. 

 

6.  Now, start your own project by saving Leaf Knowtator as a new project. Select 

Menu→File→Save Knowtator Project As… 

 

7. Save your project with your preferred name and directory by clicking the button 

„Open‟. Click OK in the next window asking you to reopen your text source collection 

if it was no longer visible 

 

Leaf Knowtator Contributors: Create a new folder „AGRON-OMICS_FirstnameLastname‟, save your 

project with the same name,. 

 

4 Setting up default annotator 
 

After starting to work with the Leaf Knowtator scheme, please create your own annotator profile 

within the project. 

 

1. Select from the menu list Knowtator→Configure… 

 

2. In the popup window work with the 'default annotator' slot, click on the 'Create Instance' 

button ( ) 

 

3. A new dialog box appears 'Select Concrete Cls'. Select 'knowtator human annotator' and click 

'OK'. 

 

4. Fill in the requested details in the third popup window. Do not write anything in the 

„annotator id‟ window. Close the window (X). 
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5 How to increase Java heap size 
 

If you are working with a large annotation file, you migth run into an error message „INFO: Exception 

caught--java-lang-OutOfMemoryError: Java heap space‟ in the start up script. In this case, you have 

to manually increase the heap size. You should not set this parameter larger than about 80% of your 

free physical memory.  

 

1. Start Protégé/Knowtator. You do not have to open any specific projects. 
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2. Go to File→Preferences menu.  

 

3. Select the „Property Files‟ tab, then the „Protege.lax‟ subtab in the popup window. 

 

4. Change the numerical value of the row containing „lax.nl.java.option.java.heap.size.max‟. Set 

the number to a value that you think your system can handle such as 500,000,000, 

750,000,000, or 1,000,000,000 depending on how much RAM you have. Click „OK‟. 

 

5. You have to restart Protégé for the change to take effect. 

 

Further information: http://protegewiki.stanford.edu/wiki/Setting_Heap_Size and 

http://knowtator.sourceforge.net/trouble_shooting.shtml.  

 

 
 

 

NOTE 

If you have no experience with the Leaf Knowtator scheme, please, start working with the training 

document. For further explanation about the system, consult the Leaf Knowtator annotation structures 

document. You find detailed annotation information for the training document in Training document 

solution.  

 

Hands on tips on how to annotate a text can be found in Chapter 6. 

http://protegewiki.stanford.edu/wiki/Setting_Heap_Size
http://knowtator.sourceforge.net/trouble_shooting.shtml
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6 Starting your own paper annotation 
 

 

 

6.1 Leaf Knowtator interface and major functions: 
 

 

 

 

 
 

Leaf Knowtator has three major panels (marked with green background on the screenshot). Left panel 

accommodates the 'Classes', middle panel contains the complete text for annotation and right panel 

has the 'Slots'.  

 

Note: Slots only appear when an existing Class annotation with predefined slots is selected or a new 

annotation is made. 
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6.2 Option 1: From relations to slots (recommended) 
 

6.2.1 Creating 'Class' annotations (Relation annotations or attach ontologies to words) 

 

1. Switch to Knowtator tab. In the middle panel, select the sentence or text to be annotated that 

will result in a single relation statement. For Windows users, with the help of CTRL key non-

continuous text can be selected. Alternatively (CTRL does not work for Mac users), text span 

can be modified using the bottom right panel. (Please, consult also the section on text 

modifications.) 

 

Note: Leaf Knowtator automatically detects beginning and end of words so selection does not have to 

be exact. It excludes any punctuation characters from the first and last position of the selection. This 

could be solved by using text modifying tools described in Section 7.8. 

 

2. Select the relevant 'Class'/relation category in the left panel (Left or right mouse click on the 

name) 

 

3. Select 'Create … annotation with'… On the left panel, predefined 'Slots' appear. For better 

visualization of the slots, close the “annotator” sub-window in the bottom right corner by 

clicking on the triangle pointing downward. The additional slots appear and can be navigated 

through with the right side scroll bar. 

 

Note: Relations can be created without highlighting any text but will not be useful in a text-based 

database. 
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6.2.2 Filling in instance slots 

 

Slots that are instances have constraints on what sort of information can be filled in. 

 

1. Highlight the word(s) to be annotated. 

2. Select which slot has to be filled and click on the create instance button above. ( ) 

 

3. A dialog box 'Choose type for new annotation filling in the slot' opens up. This box contains 

all the possible entries for the slot.  

 

4. Select the correct information for the given slot and text. 

 

Either manually look for the relevant ontology. 

 

 

 
 

 

Or use the search tool built in for a query. Always use the orange button for queries or the 

ENTER key and make sure text was entered to the search field. Press OK for creating a new 

instance. 
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Note: Using the truncation symbol (*) as a substitute for any string of zero or more characters in your 

search term works in Leaf Knowtator search tools. 

 

Note: Slot instances can be created even if no text information is highlighted or information is 

missing. Adding these ontologies will create a more complete database. 

 

Note: Using the truncation symbol (*) as a substitute for any string of zero or more characters in your 

search term works in Leaf Knowtator search tools. 

 

Note: For reference, you can browse through the list of ontology terms that have already been used for 

paper annotation available as an Excel file (Leaf Knowtator ontology terms.xlsx). 

 

6.2.3 Filling in string value slots 

 

Click on the 'Add value' button ( ) and type in or copy/paste the text. Press 'OK'. 

 

6.2.4 Filling in genotype slots 

 

Genotype annotations are slightly more complicated since two types of information have to be 

attached: the type of genetic alteration and then details about the genotype such as Gene ID (AGI code 

in most cases). 

1. Highlight text describing the genotype information for annotation.  
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2. Then click on the create instance function in the “Genotype ID” box. Select the annotation, 

for example mutated gene. 

 

 
 

Note: For simplification, we only use five genotypes. For any kind of mutations „mutated gene‟ is 

used. We only specify „knock down‟ in the case of RNAi constructs. For any kind of construct that 

results in elevated expression of the given gene we use „over expressed level‟. Any other constructs or 

combination of genotypes will be annotated as „complex genotype‟. For further details, consult the 

„Annotation structures‟ document. 

 

3. Then to fill in additional details, Genotype annotation (highlighted in blue) can be opened in 

two ways. Either you can click on the genotype name as it appears in the middle panel (text), 

then selecting it from the drop down menu. Or, you can double click on the Genotype ID slot 

field. 

 

4. Fill in the Gene ID after selecting the gene name (not the genotype) as it appears in the text 

(middle panel), by clicking on the create instance function above the „Gene ID‟ box. Look for 

the appropriate TAIR10 gene annotation and click „OK‟. 

 

For a mutated gene line: 

a. Gene ID with AGI code. 

b. Genotype Zygosity- Choose from homozygous or heterozygous. 



User Manual for Leaf Knowtator 

19 

 

c. Mutant LOF GOF ID- Choose from loss-of-function or gain-of function. 

d. Mutant type: string entry for any text information about the mutant allele. 

 

 
 

For and overexpression line, the slot boxes appear in this order: 

a. Construct description: string entry if relevant. 

b. Gene ID with AGI code. 

c. Genotype Zygosity- Choose from homozygous or heterozygous. 

 

 
 

6.3 Option 2: From slots to relation classes (takes more time) 
 

6.3.1 Annotate and attach ontologies to words  

 

1. Highlight the word to be annotated in the middle panel. 

 

2. Search for the relevant ontology either manually or use the search tool on the bottom of the 

left panel. 

 

3. Click on the class name and use the 'Create … annotation with'… function. 

 

4. Repeat steps for all the information needed for a relation annotation. 
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Note: Search function slot sometimes mysteriously disappears from the left panel! We have no 

explanation and no solution 

 

 

6.3.2 Creating relation ontology 

 

1. Highlight the text to be annotated in the middle panel. 

 

2. Select the relevant 'Class'/relation category in the left panel (Left or right mouse click on the 

name) 

 

3. Select 'Create … annotation with'… On the left panel, predefined 'Slots' appear. 

 

 

6.3.3 Fill in slots with annotated information (instances) 

 

1. Click on the annotated word. (right or left click) 

 

2. From the drop down menu, select the slot you want to fill.  

 

Note: Only those slots appear that were previously connected to the annotated class. 

 

Note: You still advised to fill the slots where information is not verbalized in the text.  

 

Note: This method can be used if an annotation is used in multiple relations. There is no need to 

reannotate the words and attach ontologies again. 

 

6.4 How to find the right ontology term 
 

The most difficult part of the project is to get familiar with the existing ontologies and to pick the 

most appropriate terms when building relations. As already mentioned you can search for ontology 

terms within the Leaf Knowtator window. 

We have created Supplemental Table S4. It lists all the terms included in the KnownLeaf annotations, 

based on 283 primary research papers. We foresee that the vast majority of additional relationships 

can be built on the basis of this focused vocabulary list. 

If an appropriate term cannot be found in this list, we recommend using the following site to search 

for the right formulation in http://www.ebi.ac.uk/ontology-lookup/. Other useful resources are 

http://www.obofoundry.org/ and http://bioportal.bioontology.org/. 

  

http://www.ebi.ac.uk/ontology-lookup/
http://www.obofoundry.org/
http://bioportal.bioontology.org/
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7 General Leaf Knowtator functions 
 

7.1 Setting up a text library 
 

Leaf Knowtator Contributors: In the case of the Leaf Knowtator project, we have created „New 

papers‟ folder that is provided with the shared files and contains only the training document. 

However, we recommend moving this folder into the same directory with your own project and 

adding further text files to this collection. Make sure that the correct text source is selected (see 

description below). 

 

 

1. Create a destination text folder on your hard drive. 

 

2. Click on the 'open text source collection' button. 

 

3. Select 'Local Files'. 

 

4. Navigate to the correct folder and click open. 

 

 
 

7.2 Adding and handling text files 
 

Note: Leaf Knowtator only works with text files. 

 

 

Option 1: Manual copy-paste 

 

1. Search for your paper of interest. 
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2. Html version- select the whole text, copy then paste as text it into a text editor program. If 

necessary, clean up and segment the text. 

 

Pdf version- it is also possible to copy paste. Beware that figure legends, headers and footers 

can interrupt sentences and paragraphs. It is worthwhile to check and keep continuity. 

 

3. Save the text file with your preferred name. 

 

 

Leaf Knowtator Contributors: Save the file as text using the PubMed ID number (only the number) as 

name. In Microsoft Word, use 'File'→'Save as...'. Select 'Save as type' plain text. Tick 'Other 

encoding' on the popup window. Choose UTF-8 from the scroll menu.  

 

Note: Unusual characters such as Greek letters are not imported properly to Leaf Knowtator if other 

encoding is used. 

 

 

Option 2: Automatic pdf conversion into text format. 

 

Use your choice of program and method. We recommend saving text files in UTF-8 encoding. 

 

Note: Automatic conversion usually results in disrupted text. It is worthwhile to check and make sure 

all the sentences and paragraphs are intact. 

 

 

7.3 Modifying the original text source file 
 

Leaf Knowtator handles text information and annotations based on their position in the text. Once you 

have annotated a text, it is better not to make any changes in the original text file. Otherwise 

annotations and the text will not be overlapping anymore. If you have to change characters, do it 

before annotating or make sure that annotations are still where they should be. 

 

7.4 Navigating among text files in Leaf Knowtator 
 

Navigation buttons to use (from left to right): 

 

 
 

'Previous text source': switch to the previous file in the text source directory. 

 

'Select text source from list': allows selection of a text file from a dialog box based on the file name. 

 

'Next text source': switch to the next file in the text source directory. 
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'Search for text source': search tool for file name queries 

 

'Open text source collection': for selecting source directory. 

7.5 Selecting and navigating among 'Class' annotations 
 

Option 1: With the middle panel. 

 

1. You have to look for the annotation manually or use the Find function (CTRL+F). 

 

2. Click on the text that has been annotated.  

 

Note: If several annotations were made on the word you have clicked on, a drop down menu appears 

where you can select the annotation you need (see screenshot below). 

 

Note: A second click will unselect the annotation. 

 

Note: Both relation annotations and ontology annotations appear since they are both implemented as 

classes. 
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Option 2: With the left panel. 

 

Select the class you want to check annotations for (relation or ontology). By clicking on the name 

(either left or right button) a drop down menu appears. This menu can slightly differ. If annotations 

from that class are present in your screen in the midel panel the drop down menu will show some 

examples of the original text (see first inserted image below). If there are too many annotations, the 

list will start with 'more…' function. If there are no annotation from that category on the screen then 

the drop down menu only contain the 'more…' function. By clicking on 'more... ', a dialog box appears 

with all the annotations from that class (see second image below). 

 

 
 

 
 

Option 3: With navigation buttons on the menu panel. 

 

1. Select the Class you want to browse. 

 

2. Use the last two navigating buttons on the menu panel called 'select previous annotation' and 

'select next annotation'. 

 

 
 

Note: This only navigates among annotations of the same kind. 
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7.6 Deleting Class annotations 
 

1. Select Class annotation to be deleted. 

 

2. Use the function button on the right panel to permanently delete annotation 

 

 
 

 

7.7 Removing slot information 
 

If invalid information was entered into a slot, entry can be removed without deleting class 

annotations.  

 

1. Select the annotation in the slot field. 

 

2. Use the 'Remove instance' button ( ) for instance annotations or the 'Remove value' button  

( ) for string entries above the appropriate slot. 

 

Note: Knowtator plug in does not work well with Undo and Redo commands. Be careful when 

deleting annotations. 

 

7.8 Modifying text entries of annotations 
 

 

7.8.1 Adding text to existing annotations 

 

1. Select the Class annotation that needs to be modified. 

 

2. Highlight the additional text that should be added to this annotation. 

 

3. Use the right middle panel. In addition to the slot panel there are two more panels on the right 

hand side. They can be minimized by using the triangles in the upper left corner. You are 

working with the field 'spans' slot. The spans function note all the selected text corresponding 

to the annotation based on the position in the text Click on the 'Add value' button above ( ). 
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7.8.2 Remove certain spans from an annotation 

 

1. Open the middle panel on the right hand side. 

 

2. In the 'spans' field, select the span that has to be removed. 

 

3. Click on the remove instance button ( ). 

 

 

7.8.3 Modify text spans of an existing annotation 

 

1. Open the middle panel on the right hand side. 

 

2. In the 'spans' field, select the span that has to be modified. 

 

3. Use the 'span edit' buttons on the top right panel for modifying the span. These buttons only 

add single characters at a time. 

 

 
 

Buttons are (from left to right): 

 

'Grow annotation on the left side' 

 

'Shrink annotation on the left side' 

 

'Shrink annotation on the right side' 

 

'Grow annotation on the right side' 
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7.9 Superclass function 
 

In many cases, it is easier to work with a subset of ontologies for your specific purpose since the 

search tool can give quite a huge list of hits for general terms. In the Leaf Knowtator project, we 

created „Internal ontologies‟ and collected widely used terms corresponding to the different slots. 

However it can happen that new ontology term has to be added to the existing collection. Superclass 

function allows “copying” an ontology term to the chosen class including all the child terms within. 

 

1. Navigate to the Class tab. 

 

2. Browse manually for the ontology term or use the integrated search tool. 

 

3. Use the Add Superclass button. 

 

4. Choose the Class that you would like to have a virtual copy of the ontology term and press 

OK. 
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7.10 Exporting files to XML 
 

1. Select 'Knowtator'→'Export annotations to xml'. 

 

 
 

2. The following dialog box appears. Click 'OK'. 

 

 
 

3. Select the directory you want to export the XML files. 
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4. Select 'Knowtator filter' on the left panel and 'show all' on the right panel on the next dialog 

box. 

 
 

5. Select the appropriate text source folder on the left panel and then the files you would like to 

export on the right panel. Click 'OK'. 

 

 
  



User Manual for Leaf Knowtator 

30 

 

8 Building a new Knowtator project 
 

 

8.1.1 Creating Classes 

 

1. Switch to the class tab. Click on the Class Hierarchy labeled ':THING'. If it is not there 

activate it in Project→Configure... →Tab Widgets→Classes (Clses) Tab. 

 

2. Click on the 'Create Class' button.  

 

3. Enter name of the new class. 

 

4. Press enter. 

 

 
 

 

8.1.2 Creating subclasses 

 

1. Click on the name of the class in the left panel in which the new subclass belongs to. 

 

2. Follow the instructions as in creating classes. 

 

8.1.3 Modifying class names 

 

1. Click on the class name in the left panel. 
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2. Then modify the name in the name field. 

 

3. Press enter 

 

8.1.4 Deleting classes 

 

1. Switch to the class tab and click on the class name to be deleted. 

 

2. Use the 'Delete Class' button (orange X). 

 

3. Confirm command in the pop up box. 

 

Note: with deleting classes all the subclasses are deleted as well. 

 

Note: Relations and ontologies are handled as Classes in our system. 

 

 

8.1.5 Creating Slots 

 

Note: Different information types recorded for the Relations are entered as Slots in our system 

 

Option 1: Using Slot tab 

 

1. Click on the slot tab. If it is not there activate it in Project→Configure... →Tab 

Widgets→Slots Tab. 

 

2. Click on the 'Create Slot' button.  

 
 

3. Enter name. 

 

4. Choose the correct 'Value type' from the drop down menu. 'String' values are used for free 

text manual entries. While 'Instances' are used for predefined ontology entries. 

 

5. In case of instances, restrictions can be made what kind of information can be entered to the 

given slot. Use the field 'Allowed Classes'. Click on the 'Add Class' button and choose the 

correct class from the pop up box.  

For example 'Plant part' slot is attached to 'Plant Ontology' class. Several classes can be 

attributed to a single slot. 
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6. You can allow multiple entries into a single slot by clicking on 'Multiple'. 
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Option 2: Using Class tab 

 

1. Select the class in the left panel you want to add slots. Either double click on the name or 

click on the 'View class' button. 

 

2. Click on the 'Create Slot' button on the pop up window. 

 

3. Another pop up window appears. Follow the instructions as above. 

 

 
 

 

Option 3: Using Class tab 

 

1. Right click on the right panel white area under 'Template Slots'. 

 

2. Select 'Create Slot' option. 

 

3. Follow instructions as above. 
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8.1.6 Adding existing slots to Classes 

 

Option 1: 

 

1. Switch to the 'Classes' tab. Use the 'Add Slot' function. 

 

2. Choose the correct slot from the popup window. Press OK. 
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Option 2: 

 

1. On the 'Classes tab' select the class you want to add slots to. Click on the 'View class' tab or 

double click on the name. 

 

2. Use the 'Add Slot function' on the popup window. 

 

3. Choose the correct slot from the second popup window. Press OK. 

 

 

 
 

 

Option 3: 

 

4. Right click on the right panel white area under 'Template Slots'. 

 

5. Choose the correct slot from the second popup window. Press OK. 
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9 Reference 
 

If you use Knowtator for academic research please cite: 

 

inproceedings{1225791, 

 author = {Ogren, Philip V.}, 

 title = {Knowtator: a prot\'{e}g\'{e} plug-in for annotated corpus 

construction}, 

 booktitle = {Proceedings of the 2006 Conference of the North American 

Chapter of the Association for Computational Linguistics on Human Language 

Technology}, 

 year = {2006}, 

 pages = {273--275}, 

 location = {New York, New York}, 

 doi = {http://dx.doi.org/10.3115/1225785.1225791}, 

 publisher = {Association for Computational Linguistics}, 

 address = {Morristown, NJ, USA}, 

 

http://knowtator.sourceforge.net/ 

 

http://knowtator.sourceforge.net/
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